[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gNewSense-users] ATI blobs (was: runlevel 3 don't work)

From: Jason Self
Subject: Re: [gNewSense-users] ATI blobs (was: runlevel 3 don't work)
Date: Thu, 7 Jan 2010 15:32:40 -0800

On Jan 7, 2010, at 12:55 PM, Dmitry Samoyloff <address@hidden> wrote:

Jason Self wrote:
I have RV620.

OK, it's R600 family.

After it arrived I found that support for RV620 didn't appear in
radeonhd until version 1.2 and the version in the gNewSense
repositories was too old.

A quick compile later and I had a fully functional video card. The 2D
performance is just fine and I find X to be very snappy. Even my 1080p videos play well (they're using Theora and that codec admittedly isn't
very demanding in the first place.)

Do you have XVideo working (you may check it using "xvinfo" command)? If your video playback is smooth, I suppose you have it. R600 have only textured Xv, therefore it needs accelerated OpenGL working also. Recompiling driver isn't enough for that, you'd need the latest Mesa and latest DRM (direct rendering
manager) module for Radeons.

The latter contains blobs. It located either in Linux (starting from 2.6.32)
or in Mesa/Xorg. 3D acceleration wouldn't work on R600 with deblobbed
software. If you have accelerated 3D working (it could be checked seeing
"glxinfo | grep OpenGL" output) then your system is using ATI blobs.

I can check when I get home on the 17th. All I did was compile radeonhd from source (version 1.2.5, I think. I haven't bothered to upgrade to 1.3.0) and then modify my X config to use radeonhd instead. It was nice to see my LCD panel run at full resolution. There aren't any blobs, unless the act of compiling radeonhd somehow pulled in extra software over the net without my knowledge.

I'm using the kernel from because the one in gNewSense was too old for my machine.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]