[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnu-arch-users] tla PyQT frontend

From: Jody Belka
Subject: Re: [Gnu-arch-users] tla PyQT frontend
Date: Sat, 15 Nov 2003 03:55:56 -0000 (GMT)
User-agent: SquirrelMail/1.4.2

Yasushi Saito said:
> Hi all,As a part of learning process, I ended up writing a simple GUI
> frontend for tla.

I had a look, and like what I see. A few points though that might be useful:

a) The prerequisites list on the webpage doesn't mention any version
information. It might be useful to note that it requires tla1.1pre8, as
some of the commands have changed, and that the qt bindings need to be for
qt3, rather than qt2 (both of these discovered through trial and error ;)

b) The file could do with pyarch moving from py_modules to
scripts (i also removed the .py extension because i think it's then easier
to run)

c) If you are running Python 2.3, instead of an earlier version, then the
references to optik need to be changed to optparse (optik has been renamed
and bundled into the core in 2.3). There are only two lines near the top
of the script that need changing

d) Might seem pretty obvious, but for people who don't RTFM (i did, but
lots of people don't), a mention in the INSTALL file that tkdiff is needed
to look at diffs would be good.

e) People using a debian-packaged version of python need to also install
the appropriate python2.x-dev package if they want to run the setup
script, as that is where the distutils modules can be found. Might be nice
to mention this.

Hope all that's useful

knew (at) pimb (dot) org

reply via email to

[Prev in Thread] Current Thread [Next in Thread]