[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Gnu-arch-users] Revision lock problems

From: Partap
Subject: [Gnu-arch-users] Revision lock problems
Date: Sat, 27 Dec 2003 16:36:46 -0600
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031013 Thunderbird/0.3

I screwed up my mirrored archive somehow...

I accidentally committed to the mirror archive (I had trivially modified some files on my mirror site and made a log and committed in the wrong window) Then when I tried to archive-mirror to get the changes I made to the main archive, it didn't work (sorry, don't remember the error) So I tried 'tla undo' and it seemed to revert the (accidental) changes I made to the mirrored archive. however, now when I try to archive-mirror, I always get 'unable to acquire revision lock (lock held or revision already committed)'

I looked in the latest directory (patch 57) and it didn't have the ++revision-lock/+contents directories, so I tried creating them, then mirroring. I get the same error, and when I look back in the patch directory, the ++revision-lock and +changes directories have been deleted...

I thought there might be some residual side effects from the tla undo, so I just deleted the patch-57 directory entirely and tried again with the same result. Hmm...I'm stuck now. I suppose I could recreate the mirror, but it will take an hour or two to recreate the archive with the bandwidth I've been getting. Maybe somebody's got an idea how I can fix it?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]