[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnu-arch-users] Minor quibbles

From: Miles Bader
Subject: Re: [Gnu-arch-users] Minor quibbles
Date: Wed, 17 Mar 2004 18:08:40 -0500
User-agent: Mutt/1.3.28i

On Wed, Mar 17, 2004 at 08:18:28AM -0700, Pierce T. Wetter III wrote:
> 4. As some one pointed out earlier, move and mv is a bit strange, 
> better to be explicit:
>    move  (deprecate)
>    mv-id  (new name for move)
>    mv     (do id, plus file)

[I posted a long rant against this idea recently; do people simply not read
posts anymore?]

The commands are `move-id' and `mv'; `move' is a compatibility alias which I
agree should be removed.

`move-id' has different semantics than `mv' besides the id-only-or--not
difference: where `tla mv' supports general unix mv behavior (e.g., mv F1 F2
F3 DIR), move-id does not.

So the `inconsistency in naming' is _good_ -- it gives a clue that these
commands are somehow not-quite-the-same.

So no, `move-id' should _not_ just be renamed `mv-id'.

If people really are bothered by the difference, they could: rewrite move-id
to support the additional mv-like behavior, and then maybe rename it mv-id,
or alternatively, hack `mv' to add an --id-only option and get rid of move-id

My 2c: it's not worth the trouble -- move-id is a _low-level command_, it's
probably not usually used except by scripts like mine (but it's necessary for
those scripts), and there's little point to it supporting mv-like semantics.
This whole discussion is a waste of time, except that yeah, the `move' (and
`delete') aliases should be killed.

But (to repeat myself) the existing move-id should _not_ be renamed mv-id.

[Similar arguments apply to `delete-id', `delete' and `rm']

80% of success is just showing up.  --Woody Allen

reply via email to

[Prev in Thread] Current Thread [Next in Thread]