[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnu-arch-users] large archive problem

From: John A Meinel
Subject: Re: [Gnu-arch-users] large archive problem
Date: Fri, 03 Dec 2004 00:10:36 -0600
User-agent: Mozilla Thunderbird 0.9 (Windows/20041103)

Chris Teague wrote:
I'm suffering from the same symptoms as the "bug #7708 overview:
import of large (37K files) tree fails with 'broken pipe' error" guy. I'm trying to check out Wombat from the Nicta repository
( which is a custom
version of the linux kernel.  It is obviously very large, and I get a
broken pipe trying to check out the code.  I am able to check out the
last cached version (wombat--mainline--0.1--patch-42) but it gets a
broken pipe when trying to patch this up to version 43.  The version
I'm trying to check out is wombat--mainline--2.6.9--patch-25.  What I
want to do to avoid this broken pipe issue is to tla get
wombat--mainline--0.1--patch-42 and then once that is done, patch it
up to the wombat--mainline--2.6.9--patch-25 version.  How do I do
this?  I've tried using delta to create a diff between these two, but
it attempts to check out the latest one which again causes a broken
pipe.  Below is a piece of abrowse --desc which shows the relationship
from the mainline--0.1 version to the mainline--2.6.9 version.

        base-0   (tag revision of

        base-0   (tag revision of

        base-0   (tag revision of

        base-0   (tag revision of

        base-0   (tag revision of

Any suggestions would be greatly appreciated.

I don't know if this will help you, but you can try:

tla get wombat--mainline--0.1--patch-42 wombat
tla get-changeset wombat--mainline--0.1--patch-43 ,patch-43
cd wombat
tla apply-changeset ../,patch-43

That's at least another route to try.

I'm trying it right now, but I have to agree, that's a big tree. (checked out revision 42 is 291M, tarred it is 210M so some of that is lost space from all the arch ids, tar.gz is 45M)

Though I have to say, when I just tried it, I got a different error. Actually what I got was:

$ tla apply-changeset ../,patch-43/
Error encountered accessing directory (Bad address)
Path: (null)
A {arch}/wombat/wombat--mainline/wombat--mainline--0.1/address@hidden/patch-log/patch-43
M   include/asm-l4/i386/arch.h

Which sounds like there is a problem with patch-43. I don't have the time right now to really delve into this more, but it might be a starting point. (By the way, wombat is up to patch-52, are there no other cacherevs?)


Attachment: signature.asc
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]