[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Gnu-arch-users] botched invariant pest

From: Ralf Juengling
Subject: [Gnu-arch-users] botched invariant pest
Date: Sat, 30 Aug 2008 11:05:37 -0700 (PDT)


In recent days I am experiencing the same error message again
and again, a message which does not reveal anything to me:

* looking for address@hidden/lush--soc--1.4--patch-176 to compare with
* comparing to address@hidden/lush--soc--1.4--patch-176
/u/juenglin/downloads/tla-1.3.5/src/tla/libarch/invent.c:982:botched invariant
    *a < *b
PANIC: exiting on botched invariant

Whenever I run into this, the project tree becomes unusable and
I need to start a new one, find those modified files and copy
them over to the new project tree by hand.

These error message are haunting me for a couple of days now
and have not been able to make out what might trigger them to
occur. I am working on my files, do a 'tla changes' once in a
while, and suddenly I see this error.

Any help will be much appreciated.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]