[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[GNUe-dev] Changes to the minimum requirements (Python/wxPython)

From: Jason Cater
Subject: [GNUe-dev] Changes to the minimum requirements (Python/wxPython)
Date: Thu, 29 May 2003 00:48:42 -0500

The next version of GNUe Designer will no longer support Python 2.0 or
wxPython 2.2 . The new minimum requirements will be:

  * Python 2.1+
  * wxPython 2.4.0+

Python 2.1 has been out for over 2 years (April '01), so I have no
hesitation changing this requirement.  All major distributions support
either Python 2.1 or Python 2.2 in their latest "stable" release.

wxPython 2.4 is a more recent release (January '03).  I hesitate making
this requirement change, but I have spent a lot of time working around
wxPython 2.2 bugs/shortcomings and I feel the change in requirements will
benefit everyone in the long run. I will be able to spend more time adding
features/fixing shortcomings in GNUe Designer rather than working around
wx oddities, as has primarily been the case since the 0.4.x releases.

Most major distributions have packages for wxPython 2.4 available, with
the notable exception of Debian Woody.  However, since that's the distro I
use on all my production machines, I have repackaged the "unstable"
wxPython 2.4 .debs to work against the "stable" woody packages. You can
add the following to your /etc/apt/sources.list

  deb woody main

and then, as root, run:

  # apt-get update
  # apt-get install wxgtk2.4-python

These are 100% unofficial backports, and are offered as-is.  Please don't
report any bugs in this package to the Debian bug list.

Please note: You may get two warnings about the scope of "self".  This is
a warning dealing with differences between namespaces in python 2.1 (in
Woody) and python 2.2 (in Unstable.)  This can be safely ignored as 1) it
is only a warning about possible misuse of (but still valid) code, and 2)
GNUe does not use this particular part of wxPython. 

These changes only affect GNUe Designer.  The latest versions of Python
and wxPython are recommended for the other GNUe Tools, but are not
currently required.

Jason Cater
GNU Enterprise

P.S., The only other consolation I can offer is that Designer doesn't have
to be installed on every machine, only those machines used for

reply via email to

[Prev in Thread] Current Thread [Next in Thread]