[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gnugo-devel] crash in twogtp

From: bump
Subject: Re: [gnugo-devel] crash in twogtp
Date: Fri, 11 Jul 2003 11:43:18 -0700

Gunnar wrote:

> Here is a corresponding patch for twogtp. It also needs backwards
> compatibility fixing.

After the patch twogtp doesn't work with GNU Go 3.2 any more.

I think when the gtp engines are initialized, a gtp command
protocol_version needs to be sent to each engine, and if the
return value is 1 instead of 2, then the twogtp needs to behave
differently towards that engine. So where Gunnar's patch has:

-       $cmd = "genmove_black";
+       $cmd = "genmove black";

actually this line should read something like

    if ($black_protocol == 1) {
       $cmd = "genmove_black";
    } else
       $cmd = "genmove black";


reply via email to

[Prev in Thread] Current Thread [Next in Thread]