[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnumed-devel] wx 2.6/2.4

From: Karsten Hilbert
Subject: Re: [Gnumed-devel] wx 2.6/2.4
Date: Tue, 27 Sep 2005 17:50:26 +0200
User-agent: Mutt/1.5.9i

On Tue, Sep 27, 2005 at 12:28:55PM +0800, address@hidden wrote:

> try:
>         import wxversion
>         import wx
> except ImportError:
>         from wxPython import wx
> I find this very confusing.

1) try to import wxversion
   - this is available if the version you have installed
     is worth being upgraded to

2a) if successful import wx of whatever version is active

2b) if not import using the old wx2.4 style

> wx.Foo simply *doesn't work* when "from wxPython import wx" is used,
Correct (it does in my installation but then "if not
os.environ['user'] == 'ncq' :-)

> you need the rather silly "wx.wxFoo", and so it's pointless, because the
> code simply won't run.
> You can't hedge bets here. If we are moving to the new style then its
> "import wx" alone, and wx.Foo below.
> If this breaks 2.4, well, we must stay with the old style until 2.4 users are 
> ready to upgrade, whenever that is.
Well, what I am saying here is: Yes, people, go ahead making
the code work *nicely* with wx2.6 and don't worry unduly
about 2.4 anymore. IOW I have decided to be responsible for
keeping 2.4 working if I am so stubborn to want that.
However, for that to at least be theoretically possible we
need to political correct import wx. Otherwise there would
not be any chance for 2.4 to work in the first place.
Whether it *actually* works is left as an exercise to
whomever needs it.

The tilting point was that Debian Sarge now offers wx2.6 in
testing. Nothing else.

GPG key ID E4071346 @
E167 67FD A291 2BEA 73BD  4537 78B9 A9F9 E407 1346

reply via email to

[Prev in Thread] Current Thread [Next in Thread]