[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnumed-devel] 8.1 tablespaces

From: Karsten Hilbert
Subject: Re: [Gnumed-devel] 8.1 tablespaces
Date: Sun, 18 Feb 2007 10:00:41 +0100
User-agent: Mutt/1.5.13 (2006-08-11)

> Mmm,,,,,,,,............................. I could be nasty  and say 'about 
> time', but I'll say 'Hooray!' instead. Next thing you'll be using wxPython 
> 2.8 and Python1.5 and I'll really fall over.
I hope you don't suffer from osteoporosis or else I'd make
sure you don't drop too hard !-)

Anyways, we still support PG 7.4 perfectly fine - there has
not been any compelling reason so far to change that. The
only 8.x-specific feature is the tablespaces - and I only
dropped 7.4 because I was too lazy to support both (we had
the old support before the new one).

In any case, here is the real reason why we seem to "cling
to crusty old versions":


We've got users. They need a stable base to work from. So
they need us the tell them "Do these simple 3 steps and you
got everything installed". This does NOT include "get the
source here, compile it like so and force it thus into your
system". We ain't no friggin' Windows, you know.

It's all about maintainability.

If Debian Testing didn't have PostgreSQL 8.1 I wouldn't even
consider coding an officially supported feature (like
installing onto a tablespace) for it.

And wxPython 2.8 isn't in Debian Testing. The reason is
simple: It's been a rushed release. Not that that makes it
bad by default but it's not been tested and if you read the
wxPython lists bugs crop up now and then. wxPython 2.8
superceded wxPython 2.7 in record time because they wanted
to get it out the door for a certain MacOSX release
(Panther, I believe). Understandable but not reassuring.

wxPython 2.6 is available, new enough (no, it doesn't have
the latest gloss) and time-tested. It's a no-brainer install
on any decent platform. In a sense, using wxPython 2.6 is
like using PostgreSQL 8.1 - it is one release behind the
officially stable release. And there hasn't been any reason
for us to actively break 7.4 compatibility. Per-column
collation will be one, down the road.

Nevertheless, wxPython 2.8 works as well for those who want
to already install it anyways.

As soon as wxPython 2.8 hits Debian we will, of course, be
officially supporting it because it has suddenly become
*maintainable* on the platform we *sort of guarantuee*
GNUmed to work on very well - namely Debian Testing.

That will then lead to us looking at using wxPython
2.8-specific features like the AUI stuff. Believe it or not,
over time I plan on "stealing" quite a few ideas and/or code
off your AUI work (that's why I "secretly" rejoice you
meddle in such matters). But only once that became

We aren't coding this because it's cool and feels freaky.

It's all about maintainability.

Because of this ...

> Still can't do the smiley thing, so take it as implied.

... I assume you perfectly understand all of the above. I
just want to make sure we get the point across to people who
chance upon this thread by casual encounter.

Hint: Get someone to officially package wxPython 2.8 for
Debian and all this will happen sooner rather than later.


PS: GNUmed runs on PostgreSQL 8.2, too, and faster at that.
GPG key ID E4071346 @
E167 67FD A291 2BEA 73BD  4537 78B9 A9F9 E407 1346

reply via email to

[Prev in Thread] Current Thread [Next in Thread]