[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [GNUnet-developers] Problems with the latest Debian package

From: Christian Grothoff
Subject: Re: [GNUnet-developers] Problems with the latest Debian package
Date: Tue, 12 Oct 2004 13:18:31 -0500
User-agent: KMail/1.7

On Tuesday 12 October 2004 11:50, Marcos D. Marado Torres wrote:
> Greetings,
> In Debian:
> address@hidden:~# apt-show-versions gnunet
> gnunet/testing uptodate 0.6.4a-2
> address@hidden:~# gnunetd
> libgcrypt has not the expected version (version 1.3.0-cvs is required).
> Failure at at logging.c:297.
> Aborted
> address@hidden:~# apt-show-versions libgcrypt1
> libgcrypt1/testing uptodate 1.1.12-8
> address@hidden:~#
> Shouldn't the gnunet Debian package use libgcrypt1 1.3.0-cvs as a
> dependency, or something like that?

Either that, or rather I'd keep compiling it against 1.2.0 if at all possible 
(since we don't need 1.3.x, especially not before it's released!). That 
should make the binary compatible with any version above 1.2.0 (at least I 
hope so; the specific version check code is part of libgcrypt).  It does not 
work the other way round (compile against 1.3, link against 1.2 does not 
work). Note that the 'expected version' statement is printed as 1.3.0-cvs 
because that was the libgcrypt version that the Debian maintainer compiled 
the binary against.  It does not mean that this is what the GNUnet sources 


reply via email to

[Prev in Thread] Current Thread [Next in Thread]