gnunet-svn
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[GNUnet-SVN] [libmicrohttpd] 03/03: Rename _MHD_inline to _MHD_static_in


From: gnunet
Subject: [GNUnet-SVN] [libmicrohttpd] 03/03: Rename _MHD_inline to _MHD_static_inline for better readability
Date: Sun, 27 Aug 2017 20:56:27 +0200

This is an automated email from the git hooks/post-receive script.

karlson2k pushed a commit to branch master
in repository libmicrohttpd.

commit 12f65d40ac9a9351b26dc11d7dcd468a531dfe15
Author: Evgeny Grin (Karlson2k) <address@hidden>
AuthorDate: Sun Aug 20 22:53:39 2017 +0300

    Rename _MHD_inline to _MHD_static_inline for better readability
---
 configure.ac             |  4 +++-
 src/microhttpd/mhd_str.c | 28 ++++++++++++++--------------
 2 files changed, 17 insertions(+), 15 deletions(-)

diff --git a/configure.ac b/configure.ac
index c249aef1..a5a48210 100644
--- a/configure.ac
+++ b/configure.ac
@@ -241,7 +241,9 @@ done
 AS_IF([[test "x$inln_prfx" != "xnone"]],
       [
        AC_DEFINE([INLINE_FUNC],[1],[Define to 1 if your C compiler supports 
inline functions.])
-       AC_DEFINE_UNQUOTED([_MHD_inline],[static $inln_prfx],[Define to prefix 
which will be used with MHD inline functions.])
+       AC_DEFINE_UNQUOTED([_MHD_static_inline],[static $inln_prfx],[Define to 
prefix which will be used with MHD static inline functions.])
+      ], [
+       AC_DEFINE([_MHD_static_inline],[static],[Define to prefix which will be 
used with MHD static inline functions.])
       ])
 AC_MSG_RESULT([[$inln_prfx]])
 CFLAGS="$save_CFLAGS"
diff --git a/src/microhttpd/mhd_str.c b/src/microhttpd/mhd_str.c
index bb10d26f..e965be63 100644
--- a/src/microhttpd/mhd_str.c
+++ b/src/microhttpd/mhd_str.c
@@ -32,13 +32,13 @@
 #include "mhd_limits.h"
 
 #ifdef MHD_FAVOR_SMALL_CODE
-#ifdef _MHD_inline
-#undef _MHD_inline
-#endif /* _MHD_inline */
+#ifdef _MHD_static_inline
+#undef _MHD_static_inline
+#endif /* _MHD_static_inline */
 /* Do not force inlining and do not use macro functions, use normal static
    functions instead.
    This may give more flexibility for size optimizations. */
-#define _MHD_inline static
+#define _MHD_static_inline static
 #ifndef INLINE_FUNC
 #define INLINE_FUNC 1
 #endif /* !INLINE_FUNC */
@@ -56,7 +56,7 @@
  * @param c character to check
  * @return non-zero if character is lower case letter, zero otherwise
  */
-_MHD_inline bool
+_MHD_static_inline bool
 isasciilower (char c)
 {
   return (c >= 'a') && (c <= 'z');
@@ -69,7 +69,7 @@ isasciilower (char c)
  * @param c character to check
  * @return non-zero if character is upper case letter, zero otherwise
  */
-_MHD_inline bool
+_MHD_static_inline bool
 isasciiupper (char c)
 {
   return (c >= 'A') && (c <= 'Z');
@@ -82,7 +82,7 @@ isasciiupper (char c)
  * @param c character to check
  * @return non-zero if character is letter in US-ASCII, zero otherwise
  */
-_MHD_inline bool
+_MHD_static_inline bool
 isasciialpha (char c)
 {
   return isasciilower (c) || isasciiupper (c);
@@ -95,7 +95,7 @@ isasciialpha (char c)
  * @param c character to check
  * @return non-zero if character is decimal digit, zero otherwise
  */
-_MHD_inline bool
+_MHD_static_inline bool
 isasciidigit (char c)
 {
   return (c >= '0') && (c <= '9');
@@ -108,7 +108,7 @@ isasciidigit (char c)
  * @param c character to check
  * @return non-zero if character is decimal digit, zero otherwise
  */
-_MHD_inline bool
+_MHD_static_inline bool
 isasciixdigit (char c)
 {
   return isasciidigit (c) ||
@@ -123,7 +123,7 @@ isasciixdigit (char c)
  * @param c character to check
  * @return non-zero if character is decimal digit or letter, zero otherwise
  */
-_MHD_inline bool
+_MHD_static_inline bool
 isasciialnum (char c)
 {
   return isasciialpha (c) || isasciidigit (c);
@@ -139,7 +139,7 @@ isasciialnum (char c)
  * @param c character to convert
  * @return converted to lower case character
  */
-_MHD_inline char
+_MHD_static_inline char
 toasciilower (char c)
 {
   return isasciiupper (c) ? (c - 'A' + 'a') : c;
@@ -155,7 +155,7 @@ toasciilower (char c)
  * @param c character to convert
  * @return converted to upper case character
  */
-_MHD_inline char
+_MHD_static_inline char
 toasciiupper (char c)
 {
   return isasciilower (c) ? (c - 'a' + 'A') : c;
@@ -168,7 +168,7 @@ toasciiupper (char c)
  * @param c character to convert
  * @return value of decimal digit or -1 if @ c is not decimal digit
  */
-_MHD_inline int
+_MHD_static_inline int
 todigitvalue (char c)
 {
   if (isasciidigit (c))
@@ -184,7 +184,7 @@ todigitvalue (char c)
  * @param c character to convert
  * @return value of hexadecimal digit or -1 if @ c is not hexadecimal digit
  */
-_MHD_inline int
+_MHD_static_inline int
 toxdigitvalue (char c)
 {
   if (isasciidigit (c))

-- 
To stop receiving notification emails like this one, please contact
address@hidden



reply via email to

[Prev in Thread] Current Thread [Next in Thread]