[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: field editor drawing issue

From: Fred Kiefer
Subject: Re: field editor drawing issue
Date: Tue, 30 Jan 2007 14:44:58 +0100
User-agent: Thunderbird (X11/20060911)

Matt Rice schrieb:
> There seems to be an issue with gui or back wrt the field editor,
> its visible in NSSearchField and NSTableView/NSOutlineView at least
> on NSTableView select a row and then double click it to edit it,
> -editColumn:row:... is called and calls the cells -selectWithFrame:...
> or editWithFrame:...
> the field editor is added as a subview, and needs display, but is never
> displayed.
> you can type in/delete stuff, and it never displays until you hit enter...
> it works sometimes such as when you double click an unselected row,
> and sometimes when you double click a selected row.
> i can reproduce this in gorm by dropping an NSTableView, Document->Test
> interface,
>  double clicking a row and then clicking the NSScroller arrows to force
> a display
> and reflect the edited status
> the only thing i can think of is window flushing, anyhow if anyone has
> any ideas..

I was able to reproduce this problem. But with one difference, the table
view cell never became editable for me. Still, even when only
selectable, you could see the difference to the expected behaviour. This
was caused by the change to  NSCell
_setupTextWithFrame:inView:editor:delegate:range: that I did a week ago.
I could not find out, what in the change as causing this random
behaviour. So for now I did revert most of the change. Now a clip view
will be used for all editing again, but this time with a different
scroll width. For me this did remove the visual problem for NSTableView,
hope it works for you as well.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]