[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: NSAnimation...

From: Gregory John Casamento
Subject: Re: NSAnimation...
Date: Mon, 9 Apr 2007 17:41:46 -0700 (PDT)


Sometimes it helps to have a ton of compilers on your machine. ;)

I have just compiled with gcc 4.1.2.   This confirms that the problem only 
shows up on gcc releases prior to gcc 4.1.2.   We need to make sure gnustep 
compiles on gcc releases back to at least GCC 3.x.  GCC 2.95 is also supported, 
but it is not considered a showstopper if it doesn't work on that release.

I will go ahead and make the change you suggested to make it work properly on 
older releases.

Later, GJC
Gregory Casamento

----- Original Message ----
From: Fred Kiefer <address@hidden>
To: Gregory John Casamento <address@hidden>
Cc: Xavier Glattard <address@hidden>; address@hidden
Sent: Monday, April 9, 2007 8:02:03 PM
Subject: Re: NSAnimation...

Gregory John Casamento wrote:
> With a clean checkout and a clean install, I still get this:
>   Compiling file set_show_service.m ...
>  Linking tool set_show_service ...
> ../Source/./obj/ undefined reference to 
> `nsanimation_progressMarkSorter'
> collect2: ld returned 1 exit status

I had a look at the code and perhaps it helps to remove the "static
INLINE" declaration for this function. Marking it as inline does surely
not help, when it is only used as a function pointer. And as far as I
remember there where problems with functions declared as static, when
uses via function pointers on Windows. But this was years ago and is
surely not relevant for your case.
This is more a gcc problem, it should complain about the modifiers at
compile time and not at link time. Interestingly I am also using Suse
Linux, but have a gcc version 4.1.2 and there this problem does not show up.


Gnustep-dev mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]