[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[gnutls-dev] Re: gnutls vs. openldap problems

From: Simon Josefsson
Subject: [gnutls-dev] Re: gnutls vs. openldap problems
Date: Thu, 11 Aug 2005 12:19:33 +0200
User-agent: Gnus/5.110004 (No Gnus v0.4) Emacs/22.0.50 (gnu/linux)

Matthias Urlichs <address@hidden> writes:

> Hi,
> oenldap2 no longer compiles against gnutls.
> The reason are the gnutls_x509_extract_certificate_* functions.
> They now only are in gnutls-openssl, which contains GPL code and thus
> cannot be linked with openldap2. Worse, the license in libextra/openssl.c
> changed from LGPL to GPL.
> Please consider reverting this and moving this code from libextra/ to lib/.

Hi.  Sounds reasonable, except if there is a problem with those APIs.
They look rather useful to me though.  Nikos, do we want to promote
other APIs now?  In the same file, there is also
gnutls_x509_verify_certificate, I wonder if it is good.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]