[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gnutls-dev] pkg-config file for libgnutls

From: Simon Josefsson
Subject: Re: [gnutls-dev] pkg-config file for libgnutls
Date: Thu, 22 Feb 2007 07:59:12 +0100
User-agent: Gnus/5.110006 (No Gnus v0.6) Emacs/22.0.93 (gnu/linux)

Andreas Metzler <address@hidden> writes:

>> Ah, maybe fixing that bug is the real solution.  Then gnutls could
>> have:
>> Requires.private: libtasn1
>> and no 'Requires:'.
> [...]
> gnutls is not in the same boat as gtk*. None of gnutls headers include
> headers from tasn. Requires are not necessary for gnutls.

You've convinced me, I'm reverting this change.

I came up with another reason why the 'Requires: libtasn1' is wrong:
gnutls doesn't use or require libtasn1 if GnuTLS was built with

This means that Pavlov's gnutls-dev package will have to contain a
manually maintained dependency on libtasn1-dev.  For my Debian shishi
package, I had the same issue with the *-dev packages, and as far as I
can see, there is unfortunately no better way to solve it.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]