[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gnutls-dev] GNUTLS_E_INTERNAL_ERROR in _gnutls_ciphertext2compresse

From: Ludovic Courtès
Subject: Re: [gnutls-dev] GNUTLS_E_INTERNAL_ERROR in _gnutls_ciphertext2compressed
Date: Thu, 15 Nov 2007 10:07:19 +0100
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/22.1 (gnu/linux)


Nikos Mavrogiannopoulos <address@hidden> writes:

> Well... If I understand correctly your compressed data decompressed to 
> something over 2^14.  This is not allowed by the TLS 1.0 spec and this
> is the reason you see this error. Are you using gnutls for both peers? 
> Which version?

For me, it's 2.0.1 as found in Debian.  Note that it fails equally well
when using the `NULL' compression method, so the issue is probably not
related to compression.

Unfortunately, I'm unable to provide a simple test case that reproduces
the problem.  My setup involves at least one Nokia N770/N800 device (an
ARMEL thingie).  Running the same code (client + server) on x86 doesn't
yield any error.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]