[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Which license is libtasn1-config?

From: Simon Josefsson
Subject: Re: Which license is libtasn1-config?
Date: Wed, 08 Oct 2008 14:09:12 +0200
User-agent: Gnus/5.110011 (No Gnus v0.11) Emacs/22.2 (gnu/linux)

Jeff Cai <address@hidden> writes:

> Hi, Simon
> I'm confused that though libtasn1 is licensed under LGPLv2, then does
> it mean libtasn1-config also is licensed under LGPLv2?
> If not, then what is its license? GPLv3 or LGPLv2?

Hi.  Actually, I cannot find a license header in, so
I'm equally confused.

Normally build infrastructure stuff is GPLv3, so using that would be
close at hand.  Alternatively, the all-permissive license used for other
autoconf-related files may be used.  I noticed that libgcrypt uses it.

However, I would prefer to get rid of the *-config scripts.  The idea
behind *-config scripts is against the normal autoconf-approach to test
for features, and works poorly in corner cases.  Even if some users
prefers that model rather than the normal autoconf-approach, libtasn1
supports pkg-config.  Pkg-config is at least widely used, and the M4
code for it is likely more correct than libtasn1.m4.  People have
probably adapted pkg-config for some corner cases before us.

So let me propose that we remove libtasn1-config and libtasn1.m4 from
libtasn1.  Instead, we recommend developers to use the normal
autoconf-machinery to test for libraries, or if they don't like that,
that they use pkg-config.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]