grub-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

grub-mkconfig fails on every non i386-pc because of gfxterm/vbe


From: Felix Zielcke
Subject: grub-mkconfig fails on every non i386-pc because of gfxterm/vbe
Date: Wed, 03 Jun 2009 11:43:35 +0200

I wonder why nobody on this list noticed this yet.
Jordi reported this already on Debian a while ago [0]

It fails with `No suitable backend could be found for gfxterm.'
The problem is that gfxterm is used when nothing is explicitly specified
and the fonts were compiled, but the fails because vbe.mod only gets
compiled for i386-pc whereas gfxterm.mod gets compiled for every arches.

I suggest as Jordi to just change the `exit 1' to ┬┤exit 0' and telling
the user that it falls back to native terminal:

diff --git a/util/grub.d/00_header.in b/util/grub.d/00_header.in
index d8fa416..7c6ea39 100644
--- a/util/grub.d/00_header.in
+++ b/util/grub.d/00_header.in
@@ -83,7 +83,7 @@ case x${GRUB_TERMINAL_OUTPUT} in
       fi
     done
     if ! [ "${video_backend}" ] ; then
-      echo "No suitable backend could be found for gfxterm." >&2 ; exit 1
+      echo "No suitable backend could be found for gfxterm, falling back to 
native terminal." >&2 ; exit 0
     fi
 
     cat << EOF


[0] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=520846
-- 
Felix Zielcke





reply via email to

[Prev in Thread] Current Thread [Next in Thread]