[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Require at least gcc 4.2

From: Bean
Subject: Re: Require at least gcc 4.2
Date: Tue, 1 Sep 2009 22:19:53 +0800

On Tue, Sep 1, 2009 at 10:12 PM, Vladimir 'phcoder'
Serbinenko<address@hidden> wrote:
> On Tue, Sep 1, 2009 at 4:04 PM, Bean<address@hidden> wrote:
>> On Tue, Sep 1, 2009 at 9:44 PM, Vladimir 'phcoder'
>> Serbinenko<address@hidden> wrote:
>>> It looks like grub2's codebase triggers bugs in old compiler. I don't
>>> feel like we should support these compilers at all. Hence this patch.
>>> If someone wants to use older compiler he's free to patch this check
>>> out but this way he's aware that we don't support gcc prior to 4.2
>> Hi,
>> I don't think it's gcc's version that's causing the problem, it's the
>> bug of some local port like apple's gcc. In fact, I've been using
>> mingw gcc 3.4.5 for a long time and doesn't seem to have issue. It'd
>> be nice to locate the specific bug and write a small test problem to
>> check for it (something like NESTED_FUNC_ATTR), instead of reply
>> blindly on gcc version. (what if apple's gcc-4.2 also contain some bug
>> ?)
> There was a test to check for it but it was removed because there is
> no way to do such check in cross-compiler environment.
> Even if gcc<4.2 seem to work ok I think we shouldn't waste resources
> on it and officially declare a minimal requirement ("you're free to go
> under requirement but don't post bugreports if you do")


Could you post a small test problem that illustrate the bug ?


gitgrub home:
my fork page:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]