[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [RFT] Re: [Patch] [bug #26237] multiple problems with usb devices

From: Aleš Nesrsta
Subject: Re: [RFT] Re: [Patch] [bug #26237] multiple problems with usb devices
Date: Sun, 13 Jun 2010 19:47:57 +0200

Hi Vladimir,

one more idea:

Vladimir 'φ-coder/phcoder' Serbinenko wrote:
> Hello, Aleš. Today I merged usb branch into mainline. Now I've started
> some work towards hotplugging and module autoloading. Currently it just
> checks portsstatus to see newly connected devices. Touble is that if you
> disconnect a device and plug a new one at its place this routine won't
> notice anything because ports are polled only when enumerating
> usbdevices. We need a more reliable way to detect new devices. Perhaps
> we should try to assign addresses to any device without address and see
> if it responds to configuration request. If noone responds assume that
> no devices were newly connected.
> On Yeeloong 'usb' command lists hotplugged devices correctly but bulk
> transfer fails with donehead=0.

It can be result of bad toggling. If device does not accept
configuration, it does not reset toggle bits in its bulk endpoints.
But function grub_usb_set_configuration does reset of toggle bits in any
case. Perhaps function grub_usb_set_configuration should reset toggling
only if configuration is accepted by device.

Best regards

reply via email to

[Prev in Thread] Current Thread [Next in Thread]