[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: status of grub netboot in GRUB2

From: John Lumby
Subject: Re: status of grub netboot in GRUB2
Date: Sun, 5 Sep 2010 15:19:03 -0400

Vladimir Serbinenko wrote:
>> but the grub_install fails and a bash -x of it reveals,  near the end,
>> /usr/grub2/sbin/grub-setup --directory=/mnt/dkt/boot/grub 
>> --device-map=/mnt/dkt/boot/grub/ fd0
>> Invalid device `fd0'.
> Well your problem is obvious:
> /mnt/dkt/boot/ != /mnt/dkt/boot/grub/

Sorry,  it really was located in /mnt/dkt/boot/grub/ for that run -
I had moved it there but cut'n'pasted the wrong cat command

> And also it's not recommended to specify GRUB device on command line. Just 
> remove all and do:
>  /usr/grub2/sbin/grub-install --root-directory=/mnt/dkt /dev/sdc

Thanks Vladimir;  I tried that and it told me (in the bash -x trace)

350+ /usr/grub2/sbin/grub-setup --directory=/mnt/dkt/boot/grub 
--device-map=/mnt/dkt/boot/grub/ /dev/sdc
/usr/grub2/sbin/grub-setup: warn: Attempting to install GRUB to a partitionless 
disk.  This is a BAD idea..
/usr/grub2/sbin/grub-setup: warn: Embedding is not possible.  GRUB can only be 
installed in this setup by using blocklists. ...
/usr/grub2/sbin/grub-setup: error: if you really want blocklists, use --force.

so I ran it with --force
     /usr/grub2/sbin/grub-install --root-directory=/mnt/dkt --force /dev/sdc
and finally I have a bootable grub-1.98 floppy.
(I think the info on making a boot floppy needs to be updated)

So now I am trying Ian's suggestion :
insmod pxe
     [ grub prompt - no error - successful ]
root (pxe:
     error:  no such disk
root (pxe)
     error:  no such disk

Maybe I am not using the pxe function correctly?
Ian had written
>> I think you can even specify the tftp server to use by setting some 
>> variables.
I don't see any mentioned  -  I used the (pxe: syntax as described 
in the info.

Anyone suggest anything I might try?



reply via email to

[Prev in Thread] Current Thread [Next in Thread]