[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Legacy GRUB to GRUB2

From: Vladimir 'φ-coder/phcoder' Serbinenko
Subject: Re: Legacy GRUB to GRUB2
Date: Wed, 20 Jul 2011 16:18:04 +0200
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20110626 Iceowl/1.0b2 Icedove/3.1.11

On 20.07.2011 13:52, Yash Jain wrote:
> Hello All,
> I am using a legacy grub boot-loader with patches provided by GRUB-IMA
> for software integrity and  also i am using trusted GRUB for few
> families.
Treacherous GRUB isn't our software. Moreover it puts your freedom in
danger. For more info
> Now i have to upgrade it to the advanced kernel(2.6.37) which will be
> loaded on ext4 DOM,
> Could you please let me know how can i upgrade to GRUB2(because
> trusted GRUB is based on legacy GRUB) or it is still fine if i can use
> the legacy GRUB to load kernel 2.6.37.
Grab the tarball, then ./configure && make && sudo make install && sudo
grub-install /dev/sdX, replace X with boot drive. You can either reuse
your GRUB legacy config by putting following in grub.cfg:
legacy_source /boot/grub/menu.lst
Or generate modern grub.cfg with
grub-mkconfig -o /boot/grub/grub.cfg
> and also could you let me know that how can i build the legacy GRUB on
> a 64bit machine - when ever i try to build it gives me a error "error:
> GRUB requires a working absolute objcopy; upgrade your binutils".
We don't support GRUB Legacy anymore.

Vladimir 'φ-coder/phcoder' Serbinenko

Attachment: signature.asc
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]