[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Loongson 2E boot failure

From: Vladimir 'φ-coder/phcoder' Serbinenko
Subject: Re: Loongson 2E boot failure
Date: Tue, 26 Jul 2011 18:01:24 +0200
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20110626 Iceowl/1.0b2 Icedove/3.1.11

On 26.07.2011 17:53, David Kuehling wrote:
>>>>>> "Colin" == Colin Watson <address@hidden> writes:
>> On Tue, Jul 26, 2011 at 02:12:30PM +0100, Colin Watson wrote:
> [..]
>> Given the lack of output, we've been narrowing down the problem by
>> inserting infinite loops at strategic points and testing whether we
>> get back to a PMON prompt or not.  So far it looks as though the
>> failure is somewhere in grub_font_init.
> I'm not too knowledgeable about grub, but have been messing around with
> font configuration myself yesterday.  Just an idea: AFAICS
> 'grub-mkconfig' (i.e. 'update-grub') will set grub.cfg to load fonts
> From /usr/{local/,}/share, not /boot, which failed in my case, and may
> be causing trouble for you.  What happens if you put your fonts to /boot
> and update grub.cfg accordingly?
> I.e. add to (/usr/local)/etc/default/grub the line
> GRUB_FONT=/boot/grub/fonts/euro.pf2
> and run update-grub, 
The failure seemingly is at initing the subsystem, way before loading
any fonts.
> David
> _______________________________________________
> Grub-devel mailing list
> address@hidden

Vladimir 'φ-coder/phcoder' Serbinenko

Attachment: signature.asc
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]