[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: grub-probe seems to be having problems

From: Lennart Sorensen
Subject: Re: grub-probe seems to be having problems
Date: Tue, 20 Mar 2012 15:02:35 -0400
User-agent: Mutt/1.5.20 (2009-06-14)

On Tue, Mar 20, 2012 at 11:28:18AM +0100, Vladimir 'φ-coder/phcoder' Serbinenko 
> There is no need to debug. I know exactly why GRUB is confused:
> because as far as my understanding goes the superblock makes no
> sense (details in previous mail). What we need is that someone
> familiar with md tells me how this sector should be interpreted.

This is just weird.

I run grub-probe and sometimes it works and sometimes it doesn't.

Something is giving inconsistent results.  I don't know if it is a
problem in 2.6.32 kernel returning inconsistent data for the superblock,
or if grub isn't correctly initializing the superblock before filling it,
or if grub isn't actually reading the superblock properly.

Sometimes /dev/sdd2 isn't being recognized as a member of /dev/md0,
and other times it is.

By the way, the code in grub-install that tries to check if a PReP
partition is empty using 'cmp' doesn't work.  It always fails.
The suggestion it gives doesn't help.

Forcing the partition to contain an elf header makes grub-install happy,
but that's not so easy to do until you got grub already installed there.

Also a recent change to non powerpc ieee1275 in grub-install has broken
nvsetenv, since ofpath is no longer being set on powerpc.  So boot-device
isn't set anymore.  This worked a few weeks ago.

Len Sorensen

reply via email to

[Prev in Thread] Current Thread [Next in Thread]