[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


From: Dirk Herrmann
Subject: scm_c_read_string
Date: Sun, 1 Jul 2001 16:18:38 +0200 (MEST)

Hello Marius,

shouldn't we rename scm_c_read_string to scm_c_read_str?  A couple of days
ago we have agreed about using the syllable mem for <char*, size_t> pairs
because of the usage in memcpy.  In analogy, the short form 'str' could be
the right thing when dealing with 0-terminated sequences of characters,
like in strcpy.  This would clarify things in a way that we would use
'string' only in contexts, where we deal with real scheme string objects.

Just a suggestion...

Best regards,
Dirk Herrmann

reply via email to

[Prev in Thread] Current Thread [Next in Thread]