[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: scm_c_read_string

From: Marius Vollmer
Subject: Re: scm_c_read_string
Date: 01 Jul 2001 19:54:50 +0200
User-agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.0.102

Dirk Herrmann <address@hidden> writes:

> shouldn't we rename scm_c_read_string to scm_c_read_str?

Yes, good point.  I was thinking in this direction, but did not finish
it.  I will add this convention to HACKING.

As to renaming scm_c_read_string and scm_c_eval_string, couldn't they
be seen as C variants of Scheme primitives?  I'd say that str and mem
are mostly for type conversions, like mem2symbol or mem2string.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]