[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Mon, 26 Nov 2001 23:41:42 +0100 (MET)
On 25 Nov 2001, Marius Vollmer wrote:
> > What about naming the function scm_make_cell, or scm_new_cell?
> I named it scm_alloc_cell and scm_alloc_double_cell. Not sure if that
> are better names than yours...
Ah, I hadn't realized that you already had submitted your patches. Still,
I like the scm_make_cell and scm_make_double_cell names better... Maybe
we should have a voting :-)
A different thing: Why did you extract the inline functions to inline.h?
I don't think this is a good strategy: We may think of having a lot more
inline functions (scm_cons and scm_cons2 for example seem to be good
candidates). These should, IMO, be put into the header files of the
corresponding module (gc.[ch], pairs.[ch]) rather than being collected in
some inline.h and inline.c file. The property of 'being an inline
function' itself is not a good basis for grouping functions.
- memory.text, Marius Vollmer, 2001/11/23
- Re: memory.text, Dirk Herrmann, 2001/11/25
- Re: memory.text, Marius Vollmer, 2001/11/25
- Re: memory.text,
Dirk Herrmann <=
- Re: memory.text, Marius Vollmer, 2001/11/26
- Re: memory.text, Dirk Herrmann, 2001/11/26
- Re: memory.text, Rob Browning, 2001/11/27
- Re: memory.text, Marius Vollmer, 2001/11/27
- Re: memory.text, Thien-Thi Nguyen, 2001/11/27
- Re: memory.text, Dirk Herrmann, 2001/11/29