[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [WORKAROUND] Re: Installing the wrong version of

From: Rob Browning
Subject: Re: [WORKAROUND] Re: Installing the wrong version of
Date: Fri, 14 Dec 2001 15:32:14 -0600
User-agent: Gnus/5.090004 (Oort Gnus v0.04) Emacs/21.1 (i386-debian-linux-gnu)

Neil Jerram <address@hidden> writes:

> Well I've found the workaround for this, which is to call ./configure
> with the --enable-ltdl-install=yes option.
> So I'm happy that I can build CVS Guile again, but... does this mean
> that we need to reconsider the recent change from convenience to
> installable libltdl?

Hmm, not sure.  What verison of libtool are you using?

I suspect that we may not be linking libguilereadline against
everything it needs, but that's just a guess based on other lt_dlopen
load failures I've seen.

It could also be that the installed ltdl isn't as smart as the .la
files that our build tree copy of libtool is producing.

In the end, I still think we need to be using the system libtool
whenever it's a suitable version, but I'm wondering if maybe the
problem is that we need a better check to see if it's good enough.

Rob Browning
rlb,, and
GPG=1C58 8B2C FB5E 3F64 EA5C  64AE 78FE E5FE F0CB A0AD

reply via email to

[Prev in Thread] Current Thread [Next in Thread]