[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: guile-core does not build with gcc-2.95.4

From: Kevin Ryde
Subject: Re: guile-core does not build with gcc-2.95.4
Date: Mon, 14 Jul 2003 08:39:59 +1000
User-agent: Gnus/5.090019 (Oort Gnus v0.19) Emacs/21.2 (gnu/linux)

Han-Wen Nienhuys <address@hidden> writes:
> Maybe --std=gnu89 should be added by default for GCC 3.x
> compilation. Anyone knowledgeable about autoconf willing to do this?

Personally I think it's cleaner to keep such things out of the main (I think that of -Werror for instance too).  Developers
can add such stuff easily enough.

I like CPPFLAGS for extra flags.  CFLAGS is the right place, but one
can leave that to configure to establish, and instead insinuate extra
stuff by abusing CPPFLAGS.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]