[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Preparing for a 1.6.8 release.

From: Steve Ellcey
Subject: Re: Preparing for a 1.6.8 release.
Date: Wed, 19 Oct 2005 14:25:40 -0700 (PDT)

> > IA64 is set in libguile/gc_os_dep.c only for IA64 Linux.  __ia64__ is set
> > by GCC (and other compilers) for both Linux and HP-UX.  But the code
> > that is under the __ia64__ ifdef is Linux specific and will not compile
> > on HP-UX.
> I'll need to think about this for a moment.  We can't use IA64
> directly if it's only defined in gc_os_dep.c, since that's not
> something continuations.c or gc.c can see.

You are right, for some reason I was thinking of gc_os_dep.c as a header
file and thinking that continuations.c and gc.c would see the
definition.  My change would break IA64 Linux but I didn't see that
because I was testing on IA64 HP-UX where I didn't want IA64 defined

> I haven't investigated carefully yet -- do you have any idea offhand
> if the __ia64__ guarded bits in those files are absolutely Linux
> specific?  If we're not *sure*, then we'll need to reverse the sense
> of the test and just exclude HP-UX so that we don't accidentally break
> some other ia64 platform.

The code might work for other OS's, the problem on HP-UX is that HP-UX
made ucontext_t an opaque type and then provided access functions to get
the information that guile is trying to access directly from ucontext_t.
If the other OS's provide ucontext_t and let you access it directly the
code might work there.

> I can't recall if I already asked this, but could you re-try with
> the 1.6.8-rc0 archive (or current 1.6 CVS)?

I did try 1.6.8.rc0 and got the same results.

> We had a similar problem on ia64/Linux, but with rc0 it seems to have
> vanished, at least on the machine I tested.  We still have a problem
> on m68k.

Given that things don't work with 1.6.8.rc0 even after changing __ia64__
to IA64 I think it is reasonable not to address this problem for 1.6.8.

I'd like to get guile working at some point on the HP-UX IA64 platform
but I don't know if that means getting the 1.6.* branch to work or if I
should just look at the top-of-tree sources.

Steve Ellcey

reply via email to

[Prev in Thread] Current Thread [Next in Thread]