[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: A guile story

From: Ludovic Courtès
Subject: Re: A guile story
Date: Tue, 07 Nov 2006 14:01:01 +0100
User-agent: Gnus/5.110006 (No Gnus v0.6) Emacs/21.4 (gnu/linux)


Neil Jerram <address@hidden> writes:

> address@hidden (Ludovic Courtès) writes:
>> Just to share my frustration: one of the things preventing me from
>> "writing an application" currently is this:
>>   (use-modules (oop goops))
>>   (let loop ((o <class>))
>>     (gc)
>>     (loop (shallow-clone o)))
>> This yields various crashes or abortions under 1.8.  I dug a bit into it
>> this week-end without any success so far.
> Just to check: do you really mean 1.8 here?

Good question.  On my PPC machine, this (here, an "unknown type" abort
in the GC) happens with both 1.8.0 and HEAD.  But this does not occur if
the program is passed on the command-line with `-c' instead of being
loaded with `-l' (sigh...).


reply via email to

[Prev in Thread] Current Thread [Next in Thread]