[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: incompatibility between using 1.8.1 and 1.8.2

From: Andreas Rottmann
Subject: Re: incompatibility between using 1.8.1 and 1.8.2
Date: Sat, 06 Oct 2007 13:55:18 +0200
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/22.1 (gnu/linux)

Kamaraju S Kusumanchi <address@hidden> writes:

> Andreas Rottmann wrote:
>> G-Wrap also has been bitten by that; from the guile-1.8 changelog.Debian:
>> guile-1.8 (1.8.2+1-2) unstable; urgency=low
>>   * Re-enable threads.
>>  -- Rob Browning <address@hidden>  Sat, 25 Aug 2007 17:59:12 -0700
>> Apparently, enabling thread support changes the ABI; to verify this is
>> indeed the problem, try texmacs together with guile-1.8 1.8.2+1-1 - if
>> I'm correct, that should fix the segfault. Then just rebuild with the
>> latest guile-1.8 to fix the problem.
> If texmacs is compiled with guile 1.8.2+1-1, and run on a machine having
> guile 1.8.2+1-1 then there are no problems. The problem arises only if
> there is a mix of guile versions. Does change in ABI count as a bug?
If there isn't a change in the SONAME, too: Yes, IMO.

Andreas Rottmann         | address@hidden      | address@hidden | address@hidden    | GnuPG Key:
Fingerprint              | C38A 39C5 16D7 B69F 33A3  6993 22C8 27F7 35A9 92E7

Life is a sexually transmitted disease.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]