[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: is guile thought to work on Mac OS X???

From: Neil Jerram
Subject: Re: is guile thought to work on Mac OS X???
Date: Sat, 10 Jan 2009 22:47:22 +0000

2009/1/10 Greg Troxel <address@hidden>:
> I am the maintainer of the guile package in pkgsrc.
> I have a Mac OS X 10.5.6 (i386) machine, and I have built and installed
> guile 1.8.6 from pkgsrc.  guile itself runs ok, but when I do
> (use-modules (ice-9 readline))
> I get a complaint about not being able to open
> which is not too surprising as it is
> /usr/pkg/lib/libguilereadline-v-17.dylib instead, thanks to the wonder
> of apple being not quite normal.
> So I wonder
>  does anyone run guile on a mac?  If so, does readline work?

We did several fixes for versions of MacOS X in the first half of last
year, and my impression following those was that guile was then
working.  But I haven't tried it myself.

>  is load-extension expected to deal with this, and perhaps the problem
>  is a stray .so in a call that shouldn't be there?

I would guess that it is libltdl's job to know that the correct suffix
on MacOS is .dylib.

> I'll take a look and see what I find.

I hope we'll get some more replies from people who use MacOS more!


reply via email to

[Prev in Thread] Current Thread [Next in Thread]