[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: autocompilation support in master

From: dsmich
Subject: Re: autocompilation support in master
Date: Tue, 9 Jun 2009 6:31:11 -0400

---- Mark H Weaver <address@hidden> wrote: 
> On Tue, Jun 09, 2009 at 12:24:48AM +0100, Neil Jerram wrote:
> > > GUILE_AUTO_COMPILE=0 ../meta/uninstalled-env guile-tools compile -o 
> > > "language/ecmascript/spec.go" "language/ecmascript/spec.scm"
> > > ERROR: Stack overflow
> > 
> > This is still happening for me after pulling the latest master today.
> I have the same problem on Debian Lenny/x86, and am able to work
> around it by increasing the stack size resource limit.  On my system,
> "ulimit -s 16384" (within bash) before running "make" does the trick.
> Unfortunately, this is not a portable solution.

Yes, I've experienced this too.  Works for me when I bump up my stack to 9000 
from 8192.

I've also found that's it's compiler dependent.  Gcc 4.4 works I think, while 
4.3 fails.  (Not sure about that, as I'm not at that machine right now).


>     Mark

reply via email to

[Prev in Thread] Current Thread [Next in Thread]