[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Guile 1.8.7 - Licenses

From: Ludovic Courtès
Subject: Re: Guile 1.8.7 - Licenses
Date: Thu, 12 Nov 2009 14:21:01 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.1 (gnu/linux)


address@hidden writes:

> In the file LICENSE is written:
> "Guile is covered under the terms of the GNU Lesser General Public
> License, version 2.1. ..."

Roughly, libguile itself and supporting modules under ‘ice-9’ are all
LGPL.  Those other files you found as GPL’d are either build-support
programs, standalone programs, or test programs, which is fine.

>     Remove or remove and re-write or ask to the copyright holder of
> the file inet_aton.c (guile-1.8.7/libguile/) to remove the 3º clause.

This one is problematic.  Bruno Haible suggests that we should be using
‘inet_pton’ to get both IPv4 and IPv6 support, so we should just do this
(in 1.9 at least).

Out of curiosity, do you have a script to generate such reports?  I’d be
interested in it, and perhaps it’d be a useful addition to Gnulib.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]