[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: guile-gnome-0 - guile-1.6.8-6.3 - random crash

From: Andy Wingo
Subject: Re: guile-gnome-0 - guile-1.6.8-6.3 - random crash
Date: Thu, 08 Apr 2010 20:53:17 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.0.92 (gnu/linux)

Hi David,

I'm happy to help, and glad to hear things are going OK. You probably
have the largest guile-gnome-using apps out there... Also, one of these
three lists is probably enough ;)

On Thu 08 Apr 2010 20:06, David Pirotte <address@hidden> writes:

> But I have had another type of bug, which I beleive is not related to the one
> you looked at, which rarely appears and occurred today, so here it is:
>       *** glibc detected *** guile: corrupted double-linked list:
>       0x08a1ca60 ***

I couldn't tell from your backtraces what went on. Be sure to install
the debug packages so that gdb can give symbols.

>       [I know I have to port my code, it's far from being easy: it depends on
>       gtrees [recently received support from the creator to make it running in
I just downloaded,
and it seems to compile fine against 2.0. I did a (load-extension
"./libgtrees" "define_gtrees_module") and that worked, and then
(use-modules (gtrees-module)) and that worked too.

Perhaps you will be able to skip 1.8 ;-) But it should work with 1.8 as well.

>       guile-1.8 and guile-pg, a prehistoric version which will remain so until

No such luck with guile-pg, it will need patches. I even tried applying
debian's patches to see if that would help, but guile-pg uses gh.h.
Copying Thien-Thi, who appears to be the upstream: what is the right
thing to do here? Get it into a project on savannah in git hosting, no?



reply via email to

[Prev in Thread] Current Thread [Next in Thread]