[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH] First batch of numerics changes

From: Mark H Weaver
Subject: Re: [PATCH] First batch of numerics changes
Date: Sat, 29 Jan 2011 15:36:28 -0500
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.1 (gnu/linux)

Andy Wingo <address@hidden> writes:
>> * libguile/numbers.c (scm_div, scm_mod, scm_div_and_mod, scm_div0,
>>   scm_mod0, scm_div0_and_mod0): New extensible procedures `div', `mod',
>>   `div-and-mod', `div0', `mod0', `div0-and-mod0'.
> I wonder; should we use Taylor Campbell's names?  From
>  I am inclined to
> think so.  It doesn't seem to me that there is any special reason to
> take the R6RS names here.
> What do you think?

Yeah, I think you're right.  Although I find `div' and `mod' to be the
most useful integer division operators, and will always bind them to
short names in my programs, I worry that existing code out there may
bind `div' and `mod' to something else, and that would probably be bad.

I'll take care of it.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]