[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[OT?] libglade, guile-gtk and glade-xml-signal-autoconnect

From: Brett Viren
Subject: [OT?] libglade, guile-gtk and glade-xml-signal-autoconnect
Date: Tue, 29 Jan 2002 14:30:43 -0500


I tried this question on the guile-gtk list, but either it was deemed
*plonk* worthy or no one knew the answer.  Since guile-gtk questions
come up here, I thought I would give y'all a try.

I have started writing an app using guile, guile-gtk and libglade.  I
create the gui from the .glade file via the

(let ((xml (glade-xml-new "")))
  (glade-xml-signal-autoconnect xml)
;; ...

The GUI is built correctly and almost everything works very smoothly.
It is a very cool system, actually, kudos to the developers!!

The only problem is that if I attach signal handler names to widget
signals inside the glade app and then define these as functions in my
.scm file, they are not picked up.  It works to ask the XML object for
a particular widget and then do a (gtk-signal-connect ...) but this is

So, what I'd like to know is if this is expected behavior, or if I am
missing something.  Eg, do these signal handler symbols live in some
other "namespace" (right term?) than the default?

I am using guile 1.4.1, glade 0.6.2, libglade 0.17, libguilegnome 0.20
on Debian x86.
Attached are glade and scm files showing what I mean.  The signal
handler I told Glade to use with the button's signal is
"button-clicked-callback" and is defined in button.scm.

Thanks for any enlightenment, and apologies if this is too far afield
for this list.


Description: application/glade

Attachment: button.scm
Description: application/guile

reply via email to

[Prev in Thread] Current Thread [Next in Thread]