[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Guile 1.5.8 beta available for testing.

From: Rob Browning
Subject: Guile 1.5.8 beta available for testing.
Date: Mon, 26 Aug 2002 12:34:48 -0500
User-agent: Gnus/5.090006 (Oort Gnus v0.06) Emacs/21.2 (i386-pc-linux-gnu)

We are pleased to annouce the availability of Guile 1.5.8 for testing.
Please report problems to address@hidden or address@hidden

Note that the 1.5.X series is a BETA series, intended only for
testing, so please don't put it into a distribution or anything

This release is only a minor update from 1.5.7 -- guile-snarf has
been changed to not require the input file to be the first argument
after the optional -o.  Apparently this was breaking too many other
programs.  Since this update was so minor, Marius and I agreed that
the release date should remain unchanged.  So unless any release
critical bugs bugs are found beforehand, the first 1.6 stable
version, 1.6.1, will be released on or after this weekend.

You can find the beta release here:

If you're interested in testing, please try as much of the following
as is convenient:

        - Unset GUILE_LOAD_PATH.

        - Remove automake and autoconf from your path, or turn off
          their execute bits, or something.  (Users must be able to
          build from the tarfile without installing those tools.)  As
          an example, you could disable the tools during the test like

            mkdir /tmp/stub
            cat > /tmp/stub/do-nothing <<EOF
            echo warning: $0 called
            sleep 10
            exit 0
            chmod +x /tmp/stub/do-nothing
            ln /tmp/stub/do-nothing /tmp/stub/automake
            ln /tmp/stub/do-nothing /tmp/stub/autoconf  # etc

        - Configure, "make", "make check", and "make install".  Make
          sure to remove your previous install tree before the "make

        - Make sure LD_LIBRARY_PATH doesn't include anything
          unnecessary -- though at the moment it (or
          LTDL_LIBRARY_PATH) will need to include guile's lib
          directory if that directory is not already in the normal
          places libltdl looks.

        - Run the test suite on the installed version.
            ./check-guile -i [INSTALL_PATH]/bin/guile

        - Look at the install tree (with "find | sort" or similar) and
          make sure nothing seems obviously amiss.

        - Make sure readline works.

        - You might try the example code in the doc directory.


Rob Browning
rlb,, and
GPG=1C58 8B2C FB5E 3F64 EA5C  64AE 78FE E5FE F0CB A0AD

reply via email to

[Prev in Thread] Current Thread [Next in Thread]