[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GDS does not support Emacs 23?

From: William Xu
Subject: Re: GDS does not support Emacs 23?
Date: Sun, 24 Sep 2006 00:38:18 +0800
User-agent: Gnus/5.110006 (No Gnus v0.6) Emacs/22.0.50 (gnu/linux)

Neil Jerram <address@hidden> writes:

> Yes, that is a problem that isn't well handled at the moment.  I've
> been thinking about this and have two possible solutions in mind.
> 1. (Easier) Change the GDS elisp code so that the gds-server process
>    is only started when needed.  This would probably avoid most
>    occurrences of the reported problem, because most users will
>    probably do GDS stuff in just one Emacs session.
> 2. (Harder) Create a new GDS "broker" component to handle the
>    possibility of multiple Emacs sessions running multiple
>    gds-servers.
> Any thoughts/preference?

i'd prefer solution 2, but solution 1 is acceptable. As for solution 1,
maybe we could let newer gds-server override older one, just like emacs
server's way.


Q: Would you like to see the WINE list?
A: What's on it, anything expensive?
Q: No, just Solitaire and MineSweeper for now, but the WINE is free.
                -- Kevin M. Bealer, about the WINdows Emulator

reply via email to

[Prev in Thread] Current Thread [Next in Thread]