[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: guile-db

From: Greg Troxel
Subject: Re: guile-db
Date: Fri, 17 Oct 2008 07:49:03 -0400
User-agent: Gnus/5.110011 (No Gnus v0.11) Emacs/22.1 (berkeley-unix)


  "To build Guile-PG you need to have installed both the PostgreSQL
   frontend library libpq, and a version of Guile that can load binary
   module (a b c) from file a/b/ or a/b/c/ under `%load-path'."

  I believe the last bit means it'll work with guile-1.4 or guile-1.6
  (because the ability was only deprecated at this stage), but guile-1.8
  definitely no longer has this ability.

True, but to make this work in 1.8 you just have to write a single .scm
file for the module which loads the shlib and re-exports all the right
symbols.  And maybe a little else, but I am pretty sure not much.

Attachment: pgpXO9dEOCoKE.pgp
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]