[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

guile-www install.

From: R. Clayton
Subject: guile-www install.
Date: Thu, 26 Nov 2009 19:53:46 -0500
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.1 (gnu/linux)

I installed guile on a debian testing system:

  $ dpkg -l guile*
  | Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
  |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
  ||/ Name           Version        Description
  un  guile          <none>         (no description available)
  ii  guile-1.8      1.8.7+1-2      The GNU extension language and Scheme interp
  ii  guile-1.8-doc  1.8.7+1-2      Documentation for Guile 1.8
  un  guile-1.8-doc- <none>         (no description available)
  ii  guile-1.8-libs 1.8.7+1-2      Main Guile libraries


and then I wanted to install guile-www 2.26 (the latest, I believe), but ran
into this:

  ul pwd

  $ ./configure
  checking for a BSD-compatible install... /usr/bin/install -c
  checking whether build environment is sane... yes
  checking for a thread-safe mkdir -p... /bin/mkdir -p
  checking for gawk... gawk
  checking whether make sets $(MAKE)... yes
  checking whether to enable maintainer-specific portions of Makefiles... no
  checking for guile... /usr/bin/guile
  checking for guile-config... no
  configure: error: guile-config required but not found


Peeking ahead in configure, it seems it will also die when it looks for

  $ locate guile-config

  $ locate guile-tools


This suggests that something is out of whack, but I don't know (apart from the
obvious) what it might be.  What's the explanation, and the fix?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]