[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [h-e-w] Gnuserv emacs 21.1.1 error with trace back

From: Jason Rumney
Subject: Re: [h-e-w] Gnuserv emacs 21.1.1 error with trace back
Date: 29 Nov 2001 20:50:39 +0000
User-agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.1.50

Peter Fraser <address@hidden> writes:

> using the gnuserv.el from
> and
> "GNU Emacs 21.1.1 (i386-msvc-nt5.1.2600) of 2001-10-22 on buffy"
> with
> (require 'gnuserv)
> (if (load "gnuserv" 'noerror 'nomessage)

You do not need to both require and load a file, BTW.

>  Options->Customize Emacs->Top Level Customization Group
> Then pick "External group: Go to Group"
> Then pick "Locate group: Go to Group"

This appears to be the same problem as was recently reported on for the External/Processes custom group.

The problem is caused by gnuserv.el containing functions with names
that conflict with those in server.el (a standard part of Emacs), and
using one of those functions in a strange way (server-kill-buffer
overrides kill-buffer, instead of the conventional way of
supplementing standard behaviour by installing as a hook).

To customize entries in those groups, you will have to disable
gnuserv and restart Emacs first. You can then re-enable gnuserv after
you have finished customizing.

Jason Rumney

reply via email to

[Prev in Thread] Current Thread [Next in Thread]