[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[h-e-w] REPOST: ntemacs & ldapsearch

From: Sivaram Neelakantan
Subject: [h-e-w] REPOST: ntemacs & ldapsearch
Date: Sat, 2 Feb 2002 18:21:21 +0530

After some research,i reached a point where I'm wondering whether
ldapsearch has worked for anyone on NT.
If i use the windows compiled openldap, version is 2.0.19,
the files are written to c:/TEMP. Now the messages passed to emacs(I
think) is

objectclass:< file:///C:\TEMP/ldapsearch-objectclass-a00186
objectclass:< file:///C:\TEMP/ldapsearch-objectclass-b00186
emacs now interprets this as a remote file and starts ange-ftp!

This seems to happen for all ldap versions from 1.3 to 1.10 on CVS(on
Sometimes it tries to look at c:/emacs/bin/<

insert-file-contents-literally: Opening input file: no such file or
directory, c:/emacs-21.1/bin/< "C:/TEMP/"ldapsearch-uid-a00140

My current  args are

 '(ldap-ldapsearch-args (quote ("-x" "-tt" "-T\"C:/TEMP/\""
"-F\"C:/TEMP/\"" "-LLL")))
This either starts ange-ftp with the newer versions of ldap.el or
looks for the ldap files
under c:/emacs/bin. I've tried various combinations of the
above,dropping or re-arranging
them but no dice.

To repeat, has anyone got ldapsearch to work on NTemacs?

I'm attaching the ldapsearch help along.

ldapsearch: option requires an argument--h
ldapsearch: unrecognized option -h
usage: ldapsearch [options] [filter [attributes...]]
  filter RFC-2254 compliant LDAP search filter
  attributes whitespace-separated list of attribute descriptions
    which may include:
      1.1   no attributes
      *     all user attributes
      +     all operational attributes
Search options:
  -a deref   one of never (default), always, search, or find
  -A         retrieve attribute names only (no values)
  -b basedn  base dn for search
  -F prefix  URL prefix for files (default: "file://\\)
  -l limit   time limit (in seconds) for search
  -L         print responses in LDIFv1 format
  -LL        print responses in LDIF format without comments
  -LLL       print responses in LDIF format without comments
             and version
  -s scope   one of base, one, or sub (search scope)
  -S attr    sort the results by attribute `attr'
  -t         write binary values to files in temporary directory
  -tt        write all values to files in temporary directory
  -T path    write files to directory specified by path (default:
  -u         include User Friendly entry names in the output
  -z limit   size limit (in entries) for search
Common options:
  -d level   set LDAP debugging level to `level'
  -D binddn  bind DN
  -f file    read operations from `file'
  -h host    LDAP server
  -H URI     LDAP Uniform Resource Indentifier(s)
  -I         use SASL Interactive mode
  -k         use Kerberos authentication
  -K         like -k, but do only step 1 of the Kerberos bind
  -M         enable Manage DSA IT control (-MM to make critical)
  -n         show what would be done but don't actually search
  -O props   SASL security properties
  -p port    port on LDAP server
  -P version procotol version (default: 3)
  -Q         use SASL Quiet mode
  -R realm   SASL realm
  -U authcid SASL authentication identity
  -v         run in verbose mode (diagnostics to standard output)
  -w passwd  bind passwd (for simple authentication)
  -W         prompt for bind passwd
  -x         Simple authentication
  -X authzid SASL authorization identity ("dn:<dn>" or "u:<user>")
  -Y mech    SASL mechanism
  -Z         Start TLS request (-ZZ to require successful response)

Attachment: InterScan_Disclaimer.txt
Description: Text document

reply via email to

[Prev in Thread] Current Thread [Next in Thread]