[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[h-e-w] can't get fixed-width fonts from X to work with NTemacs

From: Robert A. Lerche
Subject: [h-e-w] can't get fixed-width fonts from X to work with NTemacs
Date: Thu, 27 Apr 2006 09:56:26 -0700 (PDT)

I recently upgraded from NTemacs version 20.3 to 21.3.1 and I am
trying to choose a good-looking fixed-width font to use.  I am only
too well aware that the font support underwent a radical change from
emacs version 20 to 21.

I have been using an X server on my Windows system for many years (it
is an old version of StarNet's XWin32).  It came, of course, with all
the old bitmap fonts (lucidasanstypewriter-10 and -12, 6x13, etc.)

I installed the 6x13 .fon file from XWin32 in Windows.  The prior
version, NTEmacs 20.3, sees this font and uses it perfectly well --
the identifier string is "-*-6x13-normal-r-*-*-13-97-*-*-c-60-*-#44-".
I can put "-font ..."  in the shortcut and emacs launches using that
font.  Other Windows apps can see that font too and it even appears in
the font selection dialog box.

The new version, 21.3.1, does not launch if I put that "-font ..." in
the shortcut.  I still see 6x13 in the font selection dialog (Options
| Mule | Set Font/Fontset) but if I select it I get Courier instead.

I read the GNU Emacs FAQ for Windows and tried to follow the
instructions in the "How do I use bdf fonts with Emacs" section
(  I
used "getbdf" to extract 6x13 and lucidasanstypewriter-10 from my
running X server (the extracted .bdf files look OK and seem to have
fixed width bitmaps in them).

"create-fontset-from-fontset-spec" seems to run successfully and I can
then see the fontsets in the font menu (after disabling the Windows
font dialog).  However, if I select one of the fontsets, I get the
wrong bitmaps -- they are not even fixed width.

Can anyone give me a hand with this or suggest a way to diagnose the
problem further?  Thanks.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]