[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [h-e-w] AucTeX install problem on EmacsW32

From: Lennart Borgman
Subject: Re: [h-e-w] AucTeX install problem on EmacsW32
Date: Wed, 01 Nov 2006 17:29:49 +0100
User-agent: Thunderbird (Windows/20060909)

Philipp Reichmuth wrote:
Hi everybody,

I am experiencing an installation problem with AUCTeX with the patched version of EmacsW32 on Windows XP. It happens with AucTeX CVS and the 11.83 release alike. The 'make' part of the installation fails with an error in byte-compiling tex-info.el, see the make output below.

The machine is running Windows XP SP2, the TeX distribution is W32TeX,
the Emacs version is GNU Emacs (i386-mingw-nt5.1.2600)
of 2006-10-23 on W2ONE. Since the wrapper script (emacs.cmd) does not do anything useful in many situations and makes AucTeX's check for Emacs vs. XEmacs fail, I have to bypass it for the purpose of this installation. (I guess in the long run it would be less trouble if the other EmacsW32 binaries such as GnuServ etc. would be packaged in the original emacs directory. The convenience of having a command "emacs" that passes its commandline to gnuclientw is IMHO not worth the compatibility problem.)

Just rename the wrapper script emacs.cmd if it gets in your way.

Gnuserv etc is a temporary solution until emacsclient/server is ready for use on MS Windows. They will soon be that and then I will use them instead in EmacsW32.

It would be very good if you tried the same thing that you have had problem with with the unpatched EmacsW32 binaries. If you remove emacs.el, site-lisp.el and default.el files you have nothing but a bare bone Emacs. (BTW, please always try this if you have any problems.)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]