[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [h-e-w] Problems running MSYS Shell in emacsw32

From: Dirk80
Subject: Re: [h-e-w] Problems running MSYS Shell in emacsw32
Date: Thu, 6 Aug 2009 01:01:52 -0700 (PDT)

Lennart Borgman (gmail) wrote:
> On Thu, Aug 6, 2009 at 1:32 AM, Jason Rumney<address@hidden> wrote:
>> Dirk80 wrote:
>>> My .emacs file looks as follows:
>>> (custom-set-variables
>>>  ;; custom-set-variables was added by Custom.
>>>  ;; If you edit it by hand, you could mess it up, so be careful.
>>>  ;; Your init file should contain only one such instance.
>>>  ;; If there is more than one, they won't work right.
>>>  '(w32shell-msys-bin "C:\\msys\\bin")
>> c:\msys\bin would usually be a directory. The shell is normally something
>> like c:\msys\bin\sh.exe
> ... but the value above should be a directory. In my case I have
> "C:\\msys\\1.0\\bin".
> Dirk, could you please tell us how you entered this value too? (It
> could be filled in automatically by EmacsW32 if you ask it to do so in
> the Customize EmacsW32 entry in the Options menu.)


thanks for your fast help.

load-path is a variable defined in `C source code'.
Its value is 
("c:/Program Files/EmacsW32/EmacsW32/nxhtml/util/" "c:/Program
Files/EmacsW32/EmacsW32/lisp/" "c:/Program Files/EmacsW32/emacs/site-lisp"
"C:/Program Files/EmacsW32/emacs/../site-lisp" "C:/Program
Files/EmacsW32/emacs/lisp" "c:/Program Files/EmacsW32/emacs/lisp/calc"
"c:/Program Files/EmacsW32/emacs/lisp/calendar" "c:/Program
Files/EmacsW32/emacs/lisp/emacs-lisp" "c:/Program
Files/EmacsW32/emacs/lisp/emulation" "c:/Program
Files/EmacsW32/emacs/lisp/erc" "c:/Program Files/EmacsW32/emacs/lisp/eshell"
"c:/Program Files/EmacsW32/emacs/lisp/gnus" "c:/Program
Files/EmacsW32/emacs/lisp/international" "c:/Program
Files/EmacsW32/emacs/lisp/language" "c:/Program
Files/EmacsW32/emacs/lisp/mail" "c:/Program Files/EmacsW32/emacs/lisp/mh-e"
"c:/Program Files/EmacsW32/emacs/lisp/net" "c:/Program
Files/EmacsW32/emacs/lisp/nxml" "c:/Program Files/EmacsW32/emacs/lisp/org"
"c:/Program Files/EmacsW32/emacs/lisp/play" "c:/Program
Files/EmacsW32/emacs/lisp/progmodes" "c:/Program
Files/EmacsW32/emacs/lisp/textmodes" "c:/Program
Files/EmacsW32/emacs/lisp/url" "c:/Program
Files/EmacsW32/emacs/lisp/obsolete" "C:/Program Files/EmacsW32/emacs/leim")

exec-path is a variable defined in `C source code'.
Its value is 
("c:/Program Files/EmacsW32/emacs/bin/" "c:/Program Files/MiKTeX
2.7/miktex/bin" "C:/Program Files/GnuWin32/bin" " C:/Program
Files/emacs/bin" "C:/Lint" "C:/Perl/site/bin" "C:/Perl/bin"
"C:/PROGRA~1/Serena/vm/win32/bin" "C:/PROGRA~1/Serena/vm/common/bin/win32"
"C:/WINDOWS/system32" "C:/WINDOWS" "C:/WINDOWS/System32/Wbem" "C:/Program
Files/ATI Technologies/ATI.ACE/Core-Static" "C:/Program Files/Common
Files/Roxio Shared/DLLShared" "C:/Program Files/Development Tools/Notepad2"
"C:/GTK/bin" "C:/WINDOWS/system32/WindowsPowerShell/v1.0" "c:/Program

(getenv "PATH")
"c:\\Program Files\\EmacsW32\\emacs\\bin\\;C:\\Program Files\\MiKTeX
2.7\\miktex\\bin;C:\\Program Files\\GnuWin32\\bin; C:\\Program
Files\\ATI Technologies\\ATI.ACE\\Core-Static;C:\\Program Files\\Common
Files\\Roxio Shared\\DLLShared;C:\\Program Files\\Development

How did I fill it out?
I tried three different ways:

1.) Options -> Customize EmacsW32 -> Current MSYS Path -> Customize ...
Then I entered: C:\msys\bin

2.) Options -> Customize EmacsW32 -> Current MSYS Path -> Find!

3.) directly in .emacs as you have seen in my first post

But all three ways lead to the same error.

I now see that msys is not in the PATH and not in the load-path and not in
the exec-path.

View this message in context:
Sent from the Emacs - Windows - Help mailing list archive at

reply via email to

[Prev in Thread] Current Thread [Next in Thread]