[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Problem with global

From: Thomas . Marx
Subject: Problem with global
Date: Tue, 22 May 2001 13:59:00 +0200


below is a short conversation I had with Shigio Yamaguchi (Tamacom). He
asked me to forwad it to this group.


Hi again,
>> I have one root dir which contain my sources but the subdirs are linked
>> .
>> Unfortunately gtags cannot handle links.
>> So I tried setting GTAGSDBPATH and GTAGSROOT appropriate and walking
>> 'find -depth -follow ...' through my tree applying gtags to each dir.
>> The G* files are created but every entry is a './<filename>' so global
>> not> find things.
>> How can I make it going?
>Why don't you use GTAGSLIBPATH?
>% pwd/usr/src% gtags              <- at the root of source directory
>% cd /xxx/yyy/lib
>% gtags            <- at library source directory
>% cd /usr/src
>% setenv GTAGSLIBPATH /xxx/yyy/lib
>% global -x xxx

Hmm, I tried to use it like this but without success.
Unfortunately the docs don't say anything about GTAGSLIBPATH for this

I have some Qs to make things clear:
- Do I have to exec gtags in every directory where I wnat the tags from?
To the example above:
- Why are you setting the GTAGSLIBPATH after the use of gtags (and not
- Why are you not using GTAGSROOT in the example?

Back to my specific problem:
Everything (sources and global-DB) shall be under /projects.
The GTAGS... files shall be under say /projects/globaldb.
The source are under /projects/src. Within /projects/src are only symbolic
links to directories (not flat, some dirs contain dirs) containing the
So I made a script called maketags containing:
find . ! -name ".*" -depth \( -type d -o -type l \) -follow -exec tagdir {}

The script tagdir contains:
echo Tagging $1
cd $1

Before executing maketags from /projects/src I set GTAGSDBPATH and
GTAGSLIBPATH to /projects/globaldb and GTAGSROOT /projects/src.

After execution of maketags the GTAGS... files are quite huge but contain
the wrong paths to the symbols, i.e. always ./<filename>.
Seems to me like GTAGSROOT doesn't work correct.

Do you have any idea?

Thanks in advance, Tom


Thomas Marx
Traffic Control Engineering / System Analyst
Heusch/ Boesefeldt GmbH
Liebigstr. 20
D-52070 Aachen
Tel: +49(0)241-9669-283
Fax: +49(0)241-9669-177
e-mail:   address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]