[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

NTEmacs, German, ispell

From: Sören Vogel
Subject: NTEmacs, German, ispell
Date: Sat, 18 Jan 2003 14:53:42 +0100


I'm using ntemacs 21.2.1 on German Windows XP. Spell checking does
ispell and in order to provide German Umlaut support in
conjunction with the new dictionary I placed the following lines
into my .emacs:

 '(current-language-environment "German")
 '(default-input-method "german-postfix");; ???
 '(enable-multibyte-characters nil)
 '(ispell-help-in-bufferp t)
 '(ispell-local-dictionary "deutsch8")
 '(set-language-environment "German")

Seems like emacs recognizes German words, e.g. müssen (must, have
to). But ispell marks the whole word red and suggests _the same
word_ from the spelling context menu! Meaning: "You should change
"müssen" to "müssen". Okay, I cange (click on the suggested
alternative). But the word remains marked red -- misspelled. Only
picking up the word into my private dict ~/.ispell-private makes
the mark dissappearing. The line in the private dict then


I've found out that some distributed ispell German dicts contain a
bug by representing German Umlaute with "u instead of u". So I
changed the default dict with the sed command

sed 's/"\(.\)/\1"/g' wrong-dictionary > proper-dictionary

but emacs spelling behavior did not change.

Anyone suggestions?

Thanks a lot, Sören from Germany.

PS: Could you please reply via email, too.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]